Browse Source

Update requirements and remove Vagrant.

develop
Sam Black 4 years ago
parent
commit
f7eaab0560
Signed by: samwwwblack GPG Key ID: 0FF0223994EA47D8
  1. 24
      README.rst

24
README.rst

@ -18,14 +18,15 @@ Requirements
Software
--------
- Python 3 (3.4 or greater)
- PostgreSQL (9.4 or greater)
- Python 3 (3.5 or greater)
- PostgreSQL (9.5 or greater)
- Redis (2.6 or greater)
Hardware
--------
- 512MB RAM (1GB+ recommended)
- 512MB RAM
- 1CPU core
- Storage requirement will depend on the number of projects,
number and frequecy of events
@ -33,21 +34,6 @@ Hardware
5GB or so will likely be plenty for most use cases.
Setup
=====
Vagrant
-------
#. ``vagrant up``
- If you are editing the Vagrant file, use ``DNF_PROXY="proxy" vagrant up`` instead,
with a suitable caching proxy running on ``192.168.121.1:3128``
#. Goto ``http://127.0.0.1:8008`` and login.
- Default login: ``admin@cupola.example.com``:``password``
ChangeLog
=========
@ -65,7 +51,7 @@ TODO (probably)
Licence
=======
Cupola is Copyright (C) 2015-2016 Sam Black samwwwblack@lapwing.org.
Cupola is Copyright (C) 2015-2017 Sam Black samwwwblack@lapwing.org.
This program is free software: you can redistribute it and/or modify
it under the terms of the GNU Affero General Public License as published by

Loading…
Cancel
Save